Edit This Page

Working with React 0.13

If you are wanting to use Enzyme with React 0.13, but don't already have React 0.13 installed, you should do so:

npm i react@0.13 --save

Next, to get started with enzyme, you can simply install it with npm:

npm i --save-dev enzyme

And then you're ready to go! In your test files you can simply require or import enzyme:

ES6:

import { shallow, mount, render } from 'enzyme';

const wrapper = shallow(<Foo />);

ES5:

var enzyme = require('enzyme');

var wrapper = enzyme.shallow(<Foo />);